Minimum requirements (Exchange 2016)

  • Synopsis

    This guide will give you a list of the minimal requirements for Exchange 2016.
  • Applicable to

    All SherWeb 2016 hosted Exchange accounts.
  • Prerequisite

    • You must have a SherWeb 2016 hosted Exchange account.
  • How to

    To take advantage of all the benefits of our hosted Exchange offer, we highly recommend installing the following products:

     

    Minimum Web browser requirements:

     

    Internet Explorer 7 or later
    Firefox 12 or later
    Safari 5.1 or later
    Chrome 18 or later

     

    Note: Other browsers may work, but are not guaranteed to function.

     

    Minimum Operating System Requirements:

     

    Windows Vista
    Mac OS X or higher

     

    Minimum Data Connection requirements:

     

    ISDN line or higher. (Microsoft Terminal Services NOT supported)
    For mobile phone users, a data plan from your carrier in order to use ActiveSync  synchronization features.

     

    Minimum Software Requirements to use advanced Exchange Features:

     

    • Outlook 2016
    • Outlook 2013
    • Outlook 2010 with KB2965295
    • Outlook for MAC for Office 365
    • Outlook for MAC 2011

     

    Minimum Mobile requirements:

     

    Windows 8 tablet
    iOS 5 or later
    Android 4.0 or later

     

    Feel free to contact us for any other questions.

  • Keywords

    requirements, Exchange 2016
  • Was this article helpful?

    Yes    No
Top of the page

Sales

Chat offline

Support